Welcome to the MessageMedia status page. Subscribe for real-time information about the status of our service via the subscribe link above.

Social Campaigns Creation Failure – “Create” Button Not Responding

Incident Report for Sinch MessageMedia

Resolved

This incident has been resolved.
Posted Apr 17, 2026 - 22:34 AEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 17, 2026 - 22:06 AEST

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 17, 2026 - 21:19 AEST

Investigating

We are currently investigating an issue affecting Social Campaigns where users are unable to create new campaigns from the Social Messaging > All Campaigns section.
Posted Apr 17, 2026 - 19:16 AEST
This incident affected: Sinch MessageMedia - Services (The Hub).