Welcome to the MessageMedia status page. Subscribe for real-time information about the status of our service via the subscribe link above.

Investigating — Inbox Unavailable

Incident Report for Sinch MessageMedia

Resolved

The incident has been resolved and all systems are operational.
Posted May 14, 2026 - 00:46 AEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 14, 2026 - 00:34 AEST

Investigating

We’re currently investigating an issue causing Inbox to fail to load for some users. Affected users may see the following error message:

“Something unforeseen happened. We have been notified and are working on a solution.”

Our team is actively working to identify the root cause and restore service as quickly as possible. We’ll share additional updates as they become available.
Posted May 14, 2026 - 00:27 AEST
This incident affected: Sinch MessageMedia - Services (The Hub), Brands (MessageNet, DirectSMS, MobiPost, SMSCentral, WholesaleSMS, Streetdata), and External Connectivity (APAC).