Welcome to the MessageMedia status page. Subscribe for real-time information about the status of our service via the subscribe link above.

Contacts UI unavailable or failing to load

Incident Report for Sinch MessageMedia

Resolved

This incident has been resolved.
Posted May 19, 2026 - 00:10 AEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 19, 2026 - 00:07 AEST

Identified

The issue has been identified and a fix is being implemented.
Posted May 19, 2026 - 00:03 AEST

Investigating

We are currently investigating an issue affecting the Contacts section within the Sinch MessageMedia and Engage UI.

Customers may experience errors, blank pages, or inability to access or manage contacts.

Messaging delivery services and APIs are currently operating normally.

We will provide further updates as more information becomes available.
Posted May 19, 2026 - 00:03 AEST
This incident affected: Sinch MessageMedia - Services (The Hub).